Community > Forum > General Support > Disabling front page animations when login pop-up shows

Disabling front page animations when login pop-up shows

Posted by: Lourens - Tue Jan 05, 2010 9:08 pm
Post new topic Reply to topic
 [ 18 posts ] 
Disabling front page animations when login pop-up shows 
Author Message
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Disabling front page animations when login pop-up shows   Posted on: Tue Jan 05, 2010 9:08 pm
I recently noticed that logging in often fails when I click the Login button underneath the search bar on the front page. It launches a pop-up, which I use to log in, but when the next page loads, I'm still not logged in. Trying again gives me a separate page rather than a pop-up, which does work.

After some detective work, I found out that the problem is not with the site per se. What seems to happen, is that my (seven year old) computer is unable to render the animations (the changing images) on the front page completely smoothly. Thus, when the image changes, CPU usage hits 100%, and some of the key presses for my password go missing because the machine can't keep up. This of course results in a failed login.

I'd like to request two things:

- A clear error message when logging in through the pop-up fails
- Disabling the animations on the front page when the pop-up pops up

On an unrelated note: the forum overview is now called forum oversight. I'd wager our Belgian web master is to blame ;-), the Dutch word for overview being "overzicht" (oversight is "toezicht" in Dutch for those who are wondering).

Thanks!

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Moon Mission Member
Moon Mission Member
User avatar
Joined: Tue Jul 15, 2003 8:46 pm
Posts: 1215
Location: Kapellen, Antwerp, Belgium, Europe, Planet Earth, the Milky Way Galaxy
Post Re: Disabling front page animations when login pop-up shows   Posted on: Tue Jan 05, 2010 9:41 pm
Haha, and some more bugs to add to the list :) But we can't fix the slow PC.

Thanks for reporting :)

_________________
Heavier-than-air flying machines are impossible. - Lord Kelvin, 1892


Back to top
Profile WWW
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Wed Jan 06, 2010 9:04 pm
Interestingly, I just tried to log in using the pop-up box again, and despite the fact that I typed my password slowly and carefully, counting the dots (i.e. I'm pretty sure it was correct), it wouldn't log me in. Instead I was redirected to the membership page again, from where logging in using the side box worked fine. So maybe there is something funny going on on the server side after all.

You can't speed up my PC? Darn, then I'm going to have to buy that new laptop after all :).

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Space Station Member
Space Station Member
User avatar
Joined: Mon Nov 29, 2004 1:04 pm
Posts: 254
Location: Norway
Post Re: Disabling front page animations when login pop-up shows   Posted on: Thu Jan 07, 2010 11:28 am
Try deleting all cookies related to spacefellowship


Back to top
Profile ICQ
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Thu Jan 07, 2010 10:25 pm
I tried that, and it fixed another problem I had, but not this one. I can't completely rule out a problem on my end I have to say, between Firebug, NoScript, RequestBlocker, Privoxy and Tor I don't exactly have a standard configuration :). It looks like I'm the only one with this problem, which makes that possibility more likely. And I can still log in on the membership info page every time, so I'd suggest the admins spend their time on something more productive. Consider this one cancelled, or something.

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Space Station Member
Space Station Member
User avatar
Joined: Mon Nov 29, 2004 1:04 pm
Posts: 254
Location: Norway
Post Re: Disabling front page animations when login pop-up shows   Posted on: Fri Jan 08, 2010 1:45 pm
I had the same issue, and it was fixed by deleting the cookies :)


Back to top
Profile ICQ
Moon Mission Member
Moon Mission Member
User avatar
Joined: Tue Jul 15, 2003 8:46 pm
Posts: 1215
Location: Kapellen, Antwerp, Belgium, Europe, Planet Earth, the Milky Way Galaxy
Post Re: Disabling front page animations when login pop-up shows   Posted on: Fri Jan 08, 2010 2:03 pm
Cookies issue shouldn't be a problem anymore at the moment as we fixed that issue (in case it isn't for someone, let me know, contact page works without an account), the cookies issue also didn't allowed people to login on the main login page, so it was unrelated to the popup.

I have firebug in firefox etc and we test the site on all major browsers (IE, Firefox, Opera, Safari and Chrome), including different versions such as IE6, 7 & 8 etc. So no clue why there is a problem with the login popup as I can't recreate the problem. If other people experience similar issues, we'll have to debug it step by step with their support, but so far Lourens is the only one who reported it.

From a technical point of view, only the form is different, it submits the content to the same server side page as the normal login page.

_________________
Heavier-than-air flying machines are impossible. - Lord Kelvin, 1892


Back to top
Profile WWW
Spaceflight Trainee
Spaceflight Trainee
avatar
Joined: Thu Nov 19, 2009 6:45 pm
Posts: 20
Post Re: Disabling front page animations when login pop-up shows   Posted on: Tue May 04, 2010 12:52 pm
I'm not sure if this is the same issue, but I seem to have to "login" several times before I'm actually logged in. The popup box just disappears, and I have to hit login again and retry. usually twice is enough but today it took me 4 times.


Back to top
Profile
Moon Mission Member
Moon Mission Member
User avatar
Joined: Tue Jul 15, 2003 8:46 pm
Posts: 1215
Location: Kapellen, Antwerp, Belgium, Europe, Planet Earth, the Milky Way Galaxy
Post Re: Disabling front page animations when login pop-up shows   Posted on: Thu May 06, 2010 2:52 pm
vecima wrote:
I'm not sure if this is the same issue, but I seem to have to "login" several times before I'm actually logged in. The popup box just disappears, and I have to hit login again and retry. usually twice is enough but today it took me 4 times.

What browser type (Internet Explorer, Firefox, Google Chrome, Safari, Opera, etc) and version are you using?

_________________
Heavier-than-air flying machines are impossible. - Lord Kelvin, 1892


Back to top
Profile WWW
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Thu May 13, 2010 1:57 pm
Intriguingly, I just replicated the problem on my work laptop* , which is a two year old Core 2 Duo machine with 2GB RAM. And I wasn't on the front page. This machine is running Firefox 3.5.9 on Ubuntu 9.10. It's far from fully loaded at the moment.

I do have some add-ons installed, notably NoScript, RequestPolicy and Session Manager, but I'm not seeing any JavaScript errors that might indicate a problem with e.g. NoScript blocking something. Vecima, could you list any add-ons as well, if you have any?

* Today's a holiday in The Netherlands; I'm doing some work at home but goof off now and then.

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Wed May 19, 2010 9:10 pm
I just spent a bit of time trying to figure out the problem with this. I disabled all browser plug-ins except for Firebug, and then went and tried to log in. It didn't work, just like before. So I think we can rule out any interference from NoScript, RefreshBlocker or RequestPolicy.

What seems to happen is that the login form is submitted to /login?redirect=%2FForum%2F via a POST request, with the credentials. However, immediately after that, my browser does a GET request to the same URL, but without the credentials. This causes the site to simply display the login page. You can try that by clicking here while not logged in. And apparently it also causes the site to not log me in.

When I tried to repeat that request with curl, the returned HTML contained the following interesting snippet, that might explain the double request:
Code:
<div id="plWindow">
<form id="frmlogin" name="frmlogin" method="post" action="/login?redirect=%2Flogin%3Fredirect%3D%252FForum%252F">

Note the double redirect. Any idea how that might happen?

On the other hand, I'm not sure how this would keep the site from logging me in. Or could it be that you can log out by requesting /login within a session and not supplying any username/password? So that I am in fact being logged in, but then logged out again immediately afterwards?

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Moon Mission Member
Moon Mission Member
User avatar
Joined: Tue Jul 15, 2003 8:46 pm
Posts: 1215
Location: Kapellen, Antwerp, Belgium, Europe, Planet Earth, the Milky Way Galaxy
Post Re: Disabling front page animations when login pop-up shows   Posted on: Thu May 20, 2010 9:35 am
Bug is fixed, both sessions and redirect had issues.

Thanks for the help!

_________________
Heavier-than-air flying machines are impossible. - Lord Kelvin, 1892


Back to top
Profile WWW
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Mon May 31, 2010 7:24 pm
Not quite I'm afraid. It still takes me two tries to log in. But it does seem to be more consistent, before it would sometimes take up to four or five tries. I don't have time to investigate more right now, but I will once I obtain a sufficiently round tuit.

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Moon Mission Member
Moon Mission Member
User avatar
Joined: Tue Jul 15, 2003 8:46 pm
Posts: 1215
Location: Kapellen, Antwerp, Belgium, Europe, Planet Earth, the Milky Way Galaxy
Post Re: Disabling front page animations when login pop-up shows   Posted on: Wed Jun 02, 2010 5:21 pm
Lourens wrote:
Not quite I'm afraid. It still takes me two tries to log in. But it does seem to be more consistent, before it would sometimes take up to four or five tries. I don't have time to investigate more right now, but I will once I obtain a sufficiently round tuit.

I'm unable to recreate the problem, neither starting from a clean browser. Let me know if you can find a way to recreate it.

Thanks
Sigurd

_________________
Heavier-than-air flying machines are impossible. - Lord Kelvin, 1892


Back to top
Profile WWW
Space Station Commander
Space Station Commander
avatar
Joined: Thu Oct 27, 2005 7:44 am
Posts: 707
Location: Haarlem, The Netherlands
Post Re: Disabling front page animations when login pop-up shows   Posted on: Sat Jun 05, 2010 11:47 am
I think I've got it 8)

When I go to visit the forum, I type "www.spacefellowship.com/Forum" in my browser's address bar. That will get me to http://www.spacefellowship.com/Forum, where I click Login at the top right, fill out my user name and password in the pop-up, and hit Submit. This submits my credentials to http://www.spacefellowship.com/login with parameters redirect="/Forum", username=Lourens and password=<my password>.

What happens next is that the server decides that it doesn't like the www prefix, and sends back a 302 Moved Temporarily for http://spacefellowship.com/login?redirect=%2FForum%2F (so, with the redirect parameter, but without username and password). My browser dutifully follows the redirect, not reattaching the username and password parameters to the new request. Having not received a user name or password, the site can't log me in, and I end up on the separate login page, http://spacefellowship.com/login (note: without the www!).

If I then make a second attempt from there, the form is sent to http://spacefellowship.com/login with the parameters, and I am logged in.

What's funny is that I tried the same POST request to www with wget, and got 302 redirected to a new URL without www that did include the username and password parameters. I also tried starting from a clean tab, going to spacefellowship.com/Forum, and then logging in. That worked fine on the first try.

Possible solutions: 1) if I request http://www.spacefellowship.com/Forum, redirect me to http://spacefellowship.com/Forum immediately, so that the login request will be submitted without the www, or 2) fix the /login redirect from www to not-www to include username and password, or 3) set the login form to submit to the absolute URL http://spacefellowship.com/login instead of the relative /login, or 4) remove the redirect from www to non-www completely, or 5) tell me to stop being an idiot who types four characters more than necessary every time he goes to visit the forum ;).

_________________
Say, can you feel the thunder in the air? Just like the moment ’fore it hits – then it’s everywhere
What is this spell we’re under, do you care? The might to rise above it is now within your sphere
Machinae Supremacy – Sid Icarus


Back to top
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ] 
 

Who is online 

Users browsing this forum: No registered users and 18 guests


© 2014 The International Space Fellowship, developed by Gabitasoft Interactive. All Rights Reserved.  Privacy Policy | Terms of Use